
Hình 13.34. Chi tiết mẫu gia công tiện 

13.6. LẬP TRÌNH GIA CÔNG TIỆN. 

  Khác với lập trình gia công phay, việc lập trình gia công tiện được thực 

hiện trên phần mềm CAD/CAM/ProEngineer tiến hành khá đơn giản có thể 

do kết cấu của máy tiện CNC chủ yếu dao nội suy 2 trục (X, Z) với kiểu nội 

suy 2D hay 2,5D. Để lập trình gia công cho máy tiện CNC ở phần mềm 

ProEngineer cho bạn những lựa chọn sau, hình 13.33: 

+ Area: Lập trình gia công tiện trơn, cho phép bạn tiện thô hoặc 

tiện tinh. 

+ Profile: Lập trình chạy dao đường (thẳng hay cong). 

+ Groove: Lập trình gia công tiện rãnh, hay cắt đứt. 

+ Thread: Lập trình gia công tiện ren. 

+ Holemaking: Lập trình gia công lỗ. 

 13.6.1. Phương pháp lập trình gia công tiện trơn (Area): 

  Ở phần này chúng tôi xin trình bày một ví dụ minh họa việc 

thiết kế và lập trình gia công tiện thô bề mặt ngoài cho chi tiết 

như hình 13.34 theo các bước sau. 

 

 

 

 

 

 

 

 

 

 

 

 

Hình 13.33 
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- Bước 1: Xây dựng chi tiết cần gia công trên thực đơn Part, ở thực đơn này 

bạn nên tạo trước hệ thống gốc tọa độ (0XYZ) chọn làm gốc kích thước lập 

trình. Để tạo gốc tọa độ được tạo ra bằng cách pick chuột chọn biểu tượng 

(Coordinate system). Sau khi kích hoạt tính năng này, hệ thống ProE yêu cầu 

bạn thiết lập hệ thống tọa độ cho chi tiết, ở đây chúng tôi chọn mặt đầu ngoài 

cùng bên phải chi tiết mẫu làm điểm gốc chương trình, hình 13.35. Chú ý, 

trong quá trình thiết lập điểm gốc, bạn phải căn cứ theo kết cấu máy tiện 

CNC mà bạn đang sử dụng để lựa chọn hệ trục X, Y, Z trùng với hệ trục X, Y, 

Z trên máy tiện chuẩn. Pick chuột chọn OK để kết thúc và hệ thống gốc tọa 

độ được tạo ra có tên CSO. 

                 

 

 

 

 

 

 

 

 

 

 

 

- Bước 2: Khởi động thực đơn Manufacturing bằng cách pick chuột chọn biểu 

tượng New > Manufacturing > nhập tên chi tiết gia công, hình 13.36. 

 

 

 

 

 

Gốc chương 
trình 

Hình 13.35. Thiết lập gốc tọa độ 0XYZ 

Hình 13.36. Truy nhập môi trường lập trình gia công 
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  Pick chuột chọn OK, và ProE yêu cầu bạn chọn đơn vị cho hệ lập trình, ở ví 

dụ này chúng tôi chọn đơn vị cho hệ thống lập trình là mmns_mfg_nc. Pick 

chuột chọn OK và ProE thiết lập ngay môi trường làm việc mới cho bạn, hình 

13.37. 

- Bước 3: Nhập chi tiết mẫu gia công, để nhập chi tiết mẫu gia công vào môi 

trường Manufacturing bạn cần thực hiện theo các bước sau: 

  Từ thực đơn Menu Manager pick chuột chọn Mfg Model > Assemble > Ref 

Model, Pro/Engineer sẽ trình bày cửa sổ Open yêu cầu bạn tìm chi tiết cần gia 

công. Pick chọn chi tiết mẫu đã được thiết kế ở module Part với tên file là Tien.prt, 

hình 13.37. 

 

 

 

 

 

 

 

 

 

 

 

  Pick chuột chọn Open, chi tiết mẫu xuất hiện trên màn hình vẽ đi kèm một số lựa 

chọn yêu cầu bạn thiết lập vị trí tương quan cho chi tiết gia công, hình 13.38.   

   

 

 

 

 

 

Hình 13.37. Nhập chi tiết mẫu gia công 

Hình 13.38 
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  Pick chuột vào cửa sổ Automatic và lựa chọn tính năng Default 

( ) > Pick chuột chọn biểu tượng  để kết thúc tính năng, lúc này 

chi tiết gia công được đưa vào môi trường Manufacturing, hình 13.39. 

 

 

 

 

 

 

 

 

 

 

 

 

- Bước 4: Tạo phôi cho chi tiết gia công, ở đây chúng tôi tạo phôi dạng hình 

trụ bao quanh chi tiết theo trình tự sau: 

  Từ thực đơn Manufacture > Create > Workpiece, ProE yêu cầu bạn nhập 

tên cho phôi gia công, hình 13.40. 

 

 

 

 

 

 

 

 

 

Hình 13.39 

Hình 13.40 
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  Sử dụng công cụ vẽ phát để tạo phôi cho chi tiết gia công. Kết thúc lệnh vẽ 

phát tạo phôi gia công và phôi được tạo ra bao quanh chi tiết có hình màu 

xanh thể hiện trên màn hình đồ họa như hình 13.41. 

 

 

 

 

 

 

 

 

 

 

 

 

- Bước 5: Chọn máy và thiết lập gốc tọa độ. Từ cửa sổ MANUFACTURE 

bạn hãy pick chuột chọn Mfg Setup, ngay lập tức hệ thống chương trình 

Pro/Engineer sẽ trình bày cửa sổ Operation Setup, hình 13.42. 

 

 

 

 

 

 

 

 

 

 

Hình 13.41. Tạo phôi gia công 

Hình 13.42 
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  Chọn máy gia công bạn pick chuột chọn biểu tượng  từ vị trí NC 

Machine, Pro/Engineer sẽ trình bày cửa sổ Machine Tool Setup, ở đây bạn 

chọn máy gia công là máy tiện (Lathe) thay cho máy phay, hình 13.43. Pick 

chuột chọn Apply > OK để đóng cửa sổ Machine Tool Setup. 

  Kế tiếp, bạn pick chuột chọn mũi tên 

màu đen tại vị trí Machine Zero để 

thiết lập điểm O làm gốc chương trình 

gia công > Pick chuột chọn điểm gốc 

(CSO) mà ta đã tạo ra ở phần trước. 

  Pick chuột chọn mũi tên màu đen tại 

vị trí Surface để xây dựng mặt phẳng 

dừng dao, mặt phẳng bắt đầu chạy dao 

gia công > Pick chuột chọn Along Z 

Axis > Nhập khoảng cách xây dựng bề 

mặt là 10 mm, hình 13.44. 

 

 

 

 

 

 

 

 

 

 

 

- Bước 6: Lập trình gia công, ở ProE việc lập trình gia công tiện có nhiều 

điểm khác so với lập trình gia công phay. Do vậy để thuận tiện cho việc xây 

dựng chương trình sau này, ở đây bạn nên tạo trước đường cờ để xác định 

đường biên giới hạn đường chạy dao tiện, hình 13.45. 

Hình 13.43 

Hình 13.44 
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  Từ cửa sổ MANUFACTURE pick chuột chọn Machining > NC Sequence 

> Machining > Area > Done. Pro/Engineer sẽ trình bày thực đơn SEQ 

SETUP > Pick chuột chọn Name, Tool, Parameters. 

  Pick chuột chọn Done để đóng cửa sổ SEQ SETUP lại, lúc này hệ thống 

chương trình Pro/Engineer sẽ trình bày dòng nhắc “Enter NC Sequence 

name []” yêu cầu bạn nhập tên cho bước công nghệ này, sau đó nhấn phím 

enter để hệ thống ghi nhận tên cho bước công nghệ. 

   Sau khi bạn nhấn phím Enter, hệ thống chương trình Pro/Engineer sẽ trình 

bày cửa sổ Tools Setup yêu cầu bạn thiết lập thông số dao và thiết lập chế độ 

cắt, hình 13.46. 

 

 

 

 

 

 

 

 

  Pick chuột chọn Ok, ProE trình bày cửa sổ Customize, hình 13.47 yêu cầu 

bạn thiết lập đường chạy dao cho dụng cụ cắt. Pick chuột chọn Insert > Pick 

chọn biểu tượng  (Turn profile tool) > Pick chọn biểu tượng  để định 

nghĩa biên dạng chạy dao, hình 13.48. 

  

 

Hình 13.45 

Đường cờ 

Hình 13.46 
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  Pick chuột chọn đường cờ mà ta đã tạo ra ở bước trước đó, đường cờ được 

chọn sẽ chuyển sang màu vàng kèm theo các mũi tên xác định phần gia công 

cắt bỏ, hình 13.49. 

 

 

 

 

 

 

 

 

 

 

 

  Pick chuột chọn các biểu tượng  để xem trước và kết thúc quá 

trình khai báo đường chạy dao. Pick chuột chọn Done > Play path > Screen 

play với kết quả như hình 13.50. 

Hình 13.47 Hình 13.48 

Đường cờ Hình 13.49 
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- Bước 7: Mô phỏng gia công, để mô phỏng gia công, từ thực đơn NC 

SQUENCE bạn pick chuột chọn Play Path > NC Check, ProE khởi động 

module Vericut cho phép bạn thực hiện mô phỏng quá trình gia công tiện ở 

dạng 3D, hình 13.51. 

 

 

 

 

 

 

 

 

 

 

 

- Bước 8: Chuyển mã chương trình gia công, chương trình có thể áp dụng cho 

máy tiện CNC 2 trục chạy hệ điều hành Fanuc I. 

Hình 13.50 

Hình 13.51. Mô phỏng quá trình gia công tiện trơn 
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LẬP TRÌNH GIA CÔNG CNC. 

9.1: Truy nhập module Manufacturing.  

  Để truy nhập vào module Manufacturing thực hiện việc lập trình gia công cho 

máy CNC bạn cần tiến hành các bước sau: 

- Khởi động chương trình Pro/Engineer Wildfire 2.0. 

- Thiết lập thư mục làm việc cho bạn. 

- Pick chuột chọn biểu tượng  để tạo một thiết kế mới, lúc này hệ thống chương 

trình Pro/Engineer sẽ trình bày một cửa sổ New yêu cầu bạn lựa chọn các chế độ 

làm việc cho bản thiết kế của bạn. Để truy nhập vào chương trình hỗ trợ việc viết 

chương trình gia công bạn hãy pick chuột chọn Manufacturing > NC Assembly > 

Đặt tên cho bản vẽ ở mục Name > Pick chuột bỏ chế độ mặc định đơn vị, hình 9.1. 

 

 

 

 

 

 

 

 

 

 

 

- Pick chuột chọn OK để thoát khỏi cửa sổ New, 

Pro/Engineer sẽ trình bày cửa sổ New File Options yêu 

cầu bạn lựa chọn đơn vị cho bản thiết kế này > Pick 

chuột chọn mmns_mfg_nc, hình 9.2. 

- Pick chuột chọn OK để thoát khỏi cửa sổ New File 

Options, lúc này bạn đã truy nhập vào module 

Manufacturing. 

9.2: Giao diện chính của module Manufacturing. 

Hình 9.1 

Hình 9.2 
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BTHCADCAM2011 1 

            ĐẠI HỌC ĐÀ NẴNG 
TRƯỜNG CAO ĐẲNG CÔNG NGHỆ 

 
Bài 04                    BTH: CAM trong Pro/ ENGINEER 

 
Phần này cung c ấp cho SV các ki ến thức về CAM để thực hi ện gia công mô ph ỏng 
chi ti ết trên ProENGINEER 

Bài 1. LËp tr×nh gia c«ng chi tiÕt cã biªn d¹ng, hèc vµ lç  
(h×nh 4) 
 

 

H×nh 4: B¶n vÏ chi tiÕt 
 
Trong Pro/E, gia c«ng �Manufacturing� lµ mét chøc n¨ng quan träng, cho phÐp t¹o ra, 

kiÓm tra (m« pháng), söa ®æi d÷ liÖu vÒ ®−êng ch¹y dao gia c«ng. D÷ liÖu nµy cã thÓ ®−îc ghi ra 
file. NÕu cã modul hËu xö lý (Post-Processor) thÝch hîp, tõ d÷ liÖu ®−êng ch¹y dao cã thÓ t¹o ra 
ch−¬ng tr×nh NC ®Ó ®iÒu khiÓn m¸y gia c«ng. 

Tr−íc khi thùc hiÖn bµi thùc hµnh, cÇn ph¶i hiÓu mét sè kh¸i niÖm th−êng dïng trong Pro/E. 
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BTHCADCAM2011 2 

1. Mét sè kh¸i niÖm 
1.1. Qu¸ tr×nh gia c«ng (Machining Process)  
Qu¸ tr×nh thùc hiÖn c¸c thao t¸c c«ng nghÖ cÇn thiÕt ®Ó biÕn ph«i ban ®Çu thµnh chi tiÕt. 

Qu¸ tr×nh gia c«ng gåm qu¸ tr×nh c«ng nghÖ, trong ®ã cã sù trùc tiÕp t−¬ng t¸c gi÷a dao vµ ph«i 
®Ó thay ®æi kÝch th−íc, h×nh d¸ng, tÝnh chÊt c¬ lý cña ®èi t−îng vµ qu¸ tr×nh kh«ng c«ng nghÖ, 
nh− ®o, vËn chuyÓn,... ®èi t−îng. 

 
1.2. Nguyªn c«ng (Operation) 
Mét phÇn cña qu¸ tr×nh c«ng nghÖ, ®−îc ®Æc trung bëi mét m¸y (vÝ dô m¸y phay 3 trôc hay 

m¸y tiÖn), mét chi tiÕt, mét ph«i vµ mét hÖ trôc to¹ ®é x¸c ®Þnh. 
 

1.3. B−íc gia c«ng (NC Sequence) 
Mét phÇn cña nguyªn c«ng, ®−îc ®Æc tr−ng bëi mét hay mét nhãm bÒ mÆt gia c«ng (c¸c 

feature), mét dao vµ mét chÕ ®é c«ng nghÖ x¸c ®Þnh. Mét b−íc g¾n liÒn víi mét ®−êng ch¹y dao. 
 

1.4. §−êng ch¹y dao (Tool Path) 
Lµ ®−êng biÓu diÔn quü ®¹o di chuyÓn cña dao trong qu¸ tr×nh gia c«ng. Trong Pro/E, 

®−êng ch¹y dao ®−îc biÓu diÔn b»ng mét ®−êng mµu ®á vµ mòi tªn chØ h−íng di chuyÓn cña dao. 
 
1.5. C¸c yÕu tè cña qu¸ tr×nh gia c«ng 
Trong Pro/E, c¸c yÕu tè vËt chÊt cña qu¸ tr×nh gia c«ng ®−îc thÓ hiÖn d−íi d¹ng c¸c m« 

h×nh vµ th−êng ®−îc l−u thµnh c¸c file. Trong tr−êng hîp nµy, cã thÓ hiÓu yÕu tè lµ m« h×nh hay 
lµ file. Pro/E dïng c¸c file sau: 

• Ref.Model.prt (Design Model) = M« h×nh cuèi cïng ph¶i hoµn thµnh (kÕt qu¶ gia c«ng). 
Ta cã thÓ gäi t¾t lµ chi tiÕt. 

• Workpiece (Stock) = Ph«i ban ®Çu ®Ó gia c«ng ®Ó nhËn ®−îc Ref.Model. 
• Manufacture.asm = M« h×nh l¾p r¸p (Assembly) cña ph«i vµ chi tiÕt. Ph«i vµ chi tiÕt cã 

thÓ ®−îc l−u thµnh 2 file riªng biÖt hoÆc ®−îc t¹o trong cïng mét file Manuacture.Mfg. 
• Manufacture.Mfg = File chøa m« h×nh l¾p Manufacture.asm vµ c¸c d÷ liÖu c«ng nghÖ. 
•  
1.6. NhiÖm vô cña bµi thùc hµnh 
• T¹o mét ph«i bao quanh mét chi tiÕt (Ref.Model) cho tr−íc. 
• T¹o hÖ to¹ ®é ph«i. 
• Gia c«ng mét profile. 
• Gia c«ng mét hèc. 
• Khoan mét lo¹t lç. 
File m« h×nh chi tiÕt gia c«ng: Bai1.prt. 
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BTHCADCAM2011 3 

2. Tr×nh tù thùc hiÖn 
2.1. T¹o m« h×nh gia c«ng 

 

M« h×nh gia c«ng chøa chi tiÕt, 
ph«i ®−îc l¾p víi nhau vµ c¸c th«ng sè 
c«ng nghÖ liªn quan.  

B¾t ®Çu t¹o m« h×nh gia c«ng b»ng 
c¸ch chän menu New tõ menu File vµ 
chän Manufacture ⇒ NC Assembly 
nh− trong h×nh 5. Gâ vµo tªn file, vÝ dô 
Bai1. Pro/E sÏ t¹o ra file Bai1.Mfg 
trèng, s½n sµng nhËn c¸c th«ng tin h×nh 
häc vµ c«ng nghÖ gia c«ng. 

Th«ng tin ®Çu tiªn ph¶i ®−a vµo lµ 
m« h×nh chi tiÕt gia c«ng. §ã lµ file m« 
h×nh chi tiÕt d¹ng *.PRT. File m« h×nh 
dïng cho bµi thùc hµnh nµy lµ Bai1.Prt. H×nh 5: Hép tho¹i New, t¹o file 

Tõ Menu Manager 
chän MFG Model ⇒ 
Assemble ⇒ REF.Model. 
Trong danh s¸ch file hiÖn 
ra, chän Bail.prt. Chän 
Done/Return. M« h×nh chi 
tiÕt xuÊt hiÖn nh− trong 
h×nh 6. 

Th«ng tin kÕ tiÕp ®−îc 
®−a vµo m« h×nh gia c«ng 
lµ ph«i (Workpiece). 

 

H×nh 6: M« h×nh chi tiÕt (Ref.model, Design model) 
VÒ b¶n chÊt, ph«i còng lµ mét chi tiÕt nh−ng chøa d÷ liÖu h×nh häc ban ®Çu. Tr¶i qua qu¸ 

tr×nh gia c«ng, c¸c líp vËt liÖu cña ph«i sÏ ®−îc hít ®i ®Ó h×nh thµnh chi tiÕt. D÷ liÖu ph«i cã thÓ 
®−îc chøa trong file .Prt ®éc lËp hoÆc ®−îc t¹o ngay trong file m« h×nh gia c«ng. Trong bµi nµy ta 
dïng ph−¬ng ph¸p thø hai. 

Tõ Menu Manager chän MFG Model ⇒ Create ⇒ Workpeace. Pro/E nh¾c nhËp tªn 
ph«i. H·y gâ Bai1-W lµm tªn ph«i. Menu Feature quen thuéc ®Ó t¹o m« h×nh chi tiÕt xuÊt hiÖn. 
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BTHCADCAM2011 4 

 

Chän Solid ⇒ Prostrusion ⇒ 
Extrude ⇒ Solid ⇒ Done. Më 

b¶ng nhËp Extrude, chän 
Placement, Define Pro/E nh¾c 

chän Sketch Plane. Chän mÆt ®¸y 
cña m« h×nh, Flip ®Ó ®æi chiÒu 
mòi tªn, chän OK. Chän LEFT, 
chän mét trong c¸c mÆt bªn cña 

m« h×nh. Tõ thanh c«ng cô 
Sketcher, chän   ( hoÆc tõ 
menu Sketcher, Edge, Use) vµ 
chän lÇn l−ît tÊt c¶ c¸c c¹nh 
biªn cña ®Õ ch÷ nhËt (h×nh 7). 

H×nh 7: T¹o Sketch c¬ së cña ph«i 

 
Sö dông tuú chän "Edge use", kÝch th−íc ®¸y cña ph«i sÏ trïng khÝt víi ®¸y cña chi tiÕt. 

Sau khi chän tÊt c¶ c¸c c¹nh ®¸y cña chi tiÕt, lµm thµnh chu vi khÐp kÝn, chän biÓu t−îng  trªn 
thanh c«ng cô Sketcher. Quay l¹i b¶ng nhËp tham sè Extrude, ®Ó x¸c ®Þnh kho¶ng kÐo, nhËp gi¸ 
trÞ 50 vµo trong hép text ⇒ . Khèi hép biÓu diÔn ph«i xuÊt hiÖn víi mµu xanh l¸ c©y (h×nh 8). 
Ta ®· t¹o ra ®−îc m« h×nh l¾p r¸p chi tiÕt lång ph«i. 

 

 
 
Trong b−íc tiÕp theo chóng 

ta sÏ ho¹ch ®Þnh tiÕn tr×nh c«ng 
nghÖ. Chi tiÕt nµy sÏ ®−îc gia 
c«ng b»ng 1 nguyªn c«ng. §ã lµ 
nguyªn c«ng Phay, ®−îc thùc 
hiÖn trªn m¸y phay ®øng CNC 3 
trôc. Nguyªn c«ng sÏ gåm 4 
b−íc: 

 H×nh 8: M« h×nh l¾p chi tiÕt lång ph«i 
1. Phay biªn d¹ng ngoµi ®Ó t¹o h×nh khèi ch÷ "D" phÝa trªn. VËy NC Sequence ®Çu tiªn lÊy 

tªn lµ Profile. 
2. Phay hèc ch÷ nhËt. §Æt tªn NC Sequence lµ Pocket. 
3. Khoan 6 lç ∅10. §Æt tªn NC Sequence lµ Drill1. 
4. Khoan lç ∅15. §Æt tªn NC Sequence lµ Drill2. 
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C¸c th«ng sè c«ng nghÖ chÝnh ®−îc cho trong b¶ng sau. C¸c quan hÖ sau ®· ®−îc sö dông: 
Tèc ®é c¾t: )/(

1000
phv

D

v
S

π

×
=  

L−îng ch¹y dao: Sz × Z × S  (mm/ph). 
L−îng ch¹y dao r¨ng Sz lÊy cho thÐp kh«ng hîp kim lµ 0.06 mm/r. 

TT Tªn b−íc Dao v 
(m/ph) 

S (v/ph) F 
(mm/ph) 

S¬ ®å 

1 Profile Ngãn ®Çu b»ng 
D30, 4 r¨ng 

150 1500 360 
 

2 Pocket Ngãn ®Çu b»ng 
D10, 2 r¨ng 

150 4500 540 
 

3 Drill1 Ruét gµ D10 100 3000 150  
4 Drill2 Ruét gµ D15 100 2000 100  

 
2.2. T¹o nguyªn c«ng 
Trong b−íc nµy chóng ta ph¶i chän m¸y gia c«ng, x¸c ®Þnh to¹ ®é gèc ph«i, mÆt ph¼ng 

tho¸t dao. 
Qu¸ tr×nh gia c«ng chØ qua mét nguyªn c«ng. V× vËy chóng ta chØ ph¶i thùc hiÖn b−íc nµy 

mét lÇn.  
Trong Menu Manager chän  Mfg Setup më hép tho¹i Operation Setup ®Ó chän m¸y, x¸c 

®Þnh gèc to¹ ®é cña ph«i vµ mÆt ph¼ng tho¸t dao:  
1. Operation Name: §Æt tªn nguyªn c«ng. Gâ PHAY1. 
2. NC Machine: X¸c ®Þnh lo¹i m¸y gia c«ng. Lo¹i m¸y cÇn dïng lµ m¸y phay 3 trôc. Chän 
 ⇒ Mill ⇒ 3 Axis vµ nhËp c¸c tham sè vÒ m¸y, bé ®iÒu khiÓn, dao cô trong hép tho¹i 

Machine Tool Setup. Tab Comments sö dông nhËp lêi m« t¶ nguyªn c«ng, vÝ dô "Bai thuc hanh 
so 1" trong hép  tho¹i võa hiÖn ra. Sau ®ã chän OK. 

3. Mach Zero: §Þnh nghÜa hÖ to¹ ®é ph«i (th−êng gäi lµ ®iÓm Zero ph«i). Ph¶i chØ ®Þnh gèc 
to¹ ®é vµ ph−¬ng c¸c trôc X, Y, Z. HiÖn t¹i ch−a cã hÖ to¹ ®é nµo trong m« h×nh gia c«ng nªn cÇn 
ph¶i t¹o mét hÖ to¹ ®é míi. 
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H×nh 9: Hép tho¹i Operation Setup 

Chän  nót  sau ®ã chän Create ⇒ chän ph«i (®Ó g¾n hÖ to¹ ®é). Më hép tho¹i  
COORDINATE  SYSTEM. 

Víi mong muèn c¸c trôc to¹ ®é h−íng theo 3 c¹nh khèi hép cña ph«i, chóng ta chän 3 
mÆt ph¼ng kÒ nhau cña ph«i. Sau khi chän, 3 mòi tªn xuÊt hiÖn ë gãc ph«i. Trôc z h−íng lªn trªn 
hai trôc x vµ y h−íng vµo trong ph«i, nÕu cÇn sö dông nót Flip trong tab Orientation ®Ó chän 
h−íng phï hîp. 

  
H×nh  10: C¸c mòi tªn biÓu diÔn hÖ to¹ ®é ph«i 

Ph−¬ng c¸c trôc to¹ ®é ph«i ph¶i ®óng víi hÖ trôc to¹ ®é trªn m¸y, nÕu kh«ng th× khi gia 
c«ng sÏ bÞ sai kÝch th−íc.  
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§Æc biÖt, chiÒu d−¬ng 
cña trôc Z ph¶i h−íng ra 
khái ph«i, nÕu kh«ng th× sÏ 
nguy hiÓm. Dïng c¸c lÖnh 
nãi trªn ®Ó ®Þnh h−íng c¸c 
mòi tªn vµ g¸n trôc nh− 
trong h×nh 11. ChØ cÇn g¸n 
2 trôc. Trôc cßn l¹i sÏ tù 
®−îc x¸c ®Þnh theo quy t¾c 
bµn tay ph¶i. Sau khi x¸c 
®Þnh xong c¸c trôc to¹ ®é, 
menu MACH CSYS biÕn 
mÊt. BiÓu t−îng hÖ to¹ ®é 
thay thÕ cho 3 mòi tªn. H×nh 11: HÖ to¹ ®é trªn ph«i 

 

4. Retract: MÆt ph¼ng an toµn, 
x¸c ®Þnh vÞ trÝ dao tr−íc vµ sau khi 
thùc hiÖn mét b−íc gia c«ng. MÆt nµy 
ph¶i n»m ngoµi ph«i vµ c¸ch mÆt ph«i 
mét kho¶ng nhÊt ®Þnh. Trong tr−êng 
Retract t¹i vïng Surface chän nót 

 ®Ó ®Þnh nghÜa mÆt ph¼ng an toµn. 
Trong hép tho¹i (h×nh 12), chän 
Surface ⇒ Along Z Axis, gâ kho¶ng 
c¸ch theo trôc Z, vÝ dô 20 vµo « Enter 
Z Depth ⇒ OK. 

Nguyªn c«ng PHAY1 võa ®Þnh 
nghÜa xong  cßn rçng, míi chØ chøa 
c¸c th«ng sè chung, ch−a cã lÖnh gia 
c«ng nµo. Sau b−íc nµy chóng ta ph¶i 
®Þnh nghÜa c¸c b−íc c«ng nghÖ ®Ó gia 
c«ng c¸c bÒ mÆt cô thÓ. 

H×nh 12: Hép tho¹i Retract Selection 

§Ó kÕt thóc ®Þnh nghÜa nguyªn c«ng, chän OK ⇒ Done/Return. 
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2.3. T¹o c¸c b−íc (NC Sequences) 
1. Phay biªn d¹ng (Profiling) 
Trong b−íc nµy chóng ta sÏ lËp tr×nh phay theo biªn d¹ng ngoµi cña khèi h×nh ch÷ "D".  
Ph−¬ng ph¸p nµy dïng ®Ó 

phay th« hoÆc phay tinh mét bÒ 
mÆt th¼ng ®øng hoÆc xiªn. Mét 
®−êng ch¹y dao theo Profile sÏ 
®−îc t¹o ra, cã bï b¸n kÝnh dao 
®Ó ®¶m b¶o kÝch th−íc yªu cÇu.  

Trong Menu Manager, chän Machining ⇒ NC Sequence ⇒ Machining ⇒ Profile, 3 
Axis ⇒ Done. Trong hép tho¹i (h×nh 13-a), ®¸nh dÊu c¸c « Name, Comments, Tool, Parameters 
vµ Surface, sau ®ã chän ⇒ Done. NhËp c¸c th«ng tin theo yªu cÇu ®Ó t¹o ra NC Sequence. 

  
(a) (b) 

H×nh 13: Hép tho¹i ®Ó chän NC Sequence (a) vµ ®Þnh nghÜa dao (b) 
1. Name: Gâ "Profile" ®Ó ®Æt tªn cho NC Sequence ⇒ <CR>. 
2. Comments: Gâ lêi chó gi¶i, vÝ dô "Phay mat ngoai", xong bÊm OK. 
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3. Tool: §Þnh nghÜa th«ng sè dao b»ng c¸ch ®iÒn c¸c gi¸ trÞ vµo hép tho¹i võa xuÊt hiÖn nh− 
h×nh sau (h×nh 13-b). Chän trang Geometry, gâ 4 vµo « Number of teech (sè r¨ng dao). chän Apply. 
Quan s¸t sù thay ®æi h×nh häc cña dao. 

Sau khi ®Þnh nghÜa dao xong, chän OK. 
4. Parameters: Chän Set trong Menu Manager ®Ó më hép tho¹i Param tree (h×nh 14). 
X¸c ®Þnh c¸c th«ng sè c«ng nghÖ vµ ®iÒn vµo b¶ng cña hép tho¹i. ý nghÜa cña c¸c th«ng 

sè nh− sau: 
CUT_FEED: L−îng ch¹y dao, nhËp 360 (mm/ph) 
STEP_DEPTH: ChiÒu s©u mét líp c¾t, nhËp 5 (mm) 
PROF_STOCK_ALLOW: L−îng d− ®Ó l¹i theo Profile, th−êng lµ ®Ó gia c«ng tinh. NhËp 
0 (kh«ng ®Ó gia c«ng tinh). 
CHK_SRF_STOCK_ALLOW: L−îng d− trªn bÒ mÆt kiÓm so¸t va ch¹m. NÕu kh«ng ®Æt 
chÕ ®é kiÓm so¸t va ch¹m th× kh«ng nhËp gi¸ trÞ nµy. 
WALL_SCALLOP_HGT: ChiÒu s©u líp c¾t khi gia c«ng khèi (Volume Milling). Khi 
kh«ng dïng chÕ ®é nµy, ®Ó gi¸ trÞ mÆc ®Þnh (0). 
SPINDLE_SPEED: Tèc ®é trôc chÝnh, nhËp 1500 (vßng/ph). 
COOLANT_OPTION: ChÕ ®é t−íi tr¬n nguéi, nhËp OFF (kh«ng t−íi). 
CLEAR_DIST: Kho¶ng c¸ch an toµn (so víi mÆt ph¼ng an toµn). 

 
H×nh 14: Hép tho¹i nhËp th«ng sè c«ng nghÖ 

Sau khi nhËp xong c¸c th«ng sè, chän menu File ⇒ Save trong hép tho¹i. NhËp tªn file tham 
sè, chän OK. Sau ®ã chän File => Exit ®Ó kÕt thóc nhËp tham sè. 

5. Surfaces: X¸c ®Þnh bÒ mÆt (Profile) gia c«ng. 
Chän Model ⇒ Done ⇒ Add, Surface, chän chÝnh x¸c c¸c bÒ mÆt cÇn gia c«ng (h×nh 

15). Sau khi chän hÕt c¸c cung cña Profile, kÕt thóc b»ng lÖnh Done ⇒ Done/Return. 
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H×nh 1: Chän c¸c bÒ mÆt gia c«ng 

§Ó kiÓm tra kÕt qu¶, chän Play Path ⇒ Screen Play Më hép tho¹i PLAY PATH. Sau mét 
l¸t chê tÝnh to¸n, ta sÏ nh×n thÊy dao ch¹y vµ ®−êng quü ®¹o dao ®−îc vÏ ra d−íi d¹ng khung d©y. 
§Ó m« pháng d−íi d¹ng Solid, chän NC Check ⇒ Run. Trong h×nh 16 lµ kÕt qu¶ Play Path vµ NC 
Check b−íc gia c«ng Profile. 

  
H×nh 16: KÕt qu¶ gia c«ng Profile 

NÕu chÊp nhËn kÕt qu¶ th× chän Done/Return ⇒ Done Sequ ®Ó nhËn NC Sequence võa 
t¹o vµ kÕt thóc. 

2 Phay hèc (Pocketing) 
Phay hèc dïng ®Ó phay tinh mét hèc sau khi phay th« víi Volume Milling hoÆc phay tinh mét 

hèc cã s½n. BÒ mÆt ®Ó phay hèc ph¶i cho phÐp ch¹y dao liªn tôc. 
B−íc nµy nh»m phay hèc ch÷ nhËt trªn ®Ønh chi tiÕt nh− chØ ra trong m« h×nh. 

Chän Maching ⇒ NC Sequence ⇒ New Sequence ⇒ Machining ⇒ Poketing ⇒ Done. Tõ 
Menu Manager, ®¸nh chon c¸c « Name, Comments, Tool, Parameters, Surfaces. Cuèi cïng 
chän Done. 

Chän c¸c bÒ mÆt h×nh 
thµnh Profile cÇn gia c«ng 
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1. Name: Gâ tªn b−íc "Pocketing". 
2. Comments: Gâ chó gi¶i "Phay hoc chu nhat" ⇒ OK. 
3. Tool: §Ó ®Þnh nghÜa dao míi, trong hép tho¹i nh− h×nh 13-b, chän menu File ⇒ New. 

NhËp th«ng sè dao t−¬ng tù nh− dao tr−íc, chØ kh¸c tªn dao (Tool_ID) lµ 10FLAT, ®−êng kÝnh 
dao (Cutter_Diam) lµ 10, gâ 2 vµo « Number of teech (sè r¨ng dao), chän Apply. Xong chän 
OK ®Ó kÕt thóc ®Þnh nghÜa dao. 

 

4. Parameters: Chän Set tõ 
Menu Manager, hép tho¹i Param 
Tree xuÊt hiÖn víi danh môc c¸c 
th«ng sè cÇn nhËp cho Pocketing 
(h×nh 17). 

X¸c ®Þnh c¸c th«ng sè c«ng 
nghÖ vµ ®iÒn vµo b¶ng cña hép 
tho¹i. ý nghÜa cña c¸c th«ng th«ng 
sè míi gÆp nh− sau: 

BOTTOM_SCALLOP_HGT: 
ChiÒu s©u líp c¾t ë ®¸y khi gia 
c«ng khèi (Volume Milling). 

H×nh 17: Hép tho¹i nhËp th«ng sè phay hèc 
SCAN_TYPE: KiÓu c¾t. Víi phay hèc, cã thÓ 

chän c¸c kiÓu nh− h×nh 18. 
1. TYPE_1: C¾t th¼ng. GÆp ®¶o th× nhÊc dao 

qua. 
2. TYPE_SPIRAL: C¾t theo ®−êng xo¾n èc. GÆp 

®¶o th× ch¹y vßng quanh. 
3. TYPE_2: C¾t th¼ng. GÆp ®¶o th× ch¹y vßng 

quanh. 
4. TYPE_3: C¾t liªn tôc theo tõng vïng. HÕt 

mét vïng th× nhÊc dao sang vïng kh¸c. GÆp ®¶o th× 
ch¹y vßng quanh. 

5. TYPE_ONE_DIR: ChØ c¾t theo 1 chiÒu. §Õn 
cuèi ®−êng th× nhÊc dao, ch¹y vÒ phÝa ®Çu vµ c¾t tiÕp 
nh− ®−êng tr−íc. 

H×nh 18: C¸c kiÓu c¾t 
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6. TYPE_1_CONNECT: C¾t mét chiÒu. HÕt mét ®−êng th× nhÊc dao, ch¹y nhanh vÒ phÝa 
®Çu, khoan xuèng vµ c¾t tiÕp ph− cò. NÕu cã ®−êng bªn c¹nh th× c¾t nèi ®Ó tr¸nh va ch¹m. 

Khi phay hèc th−êng chän 4 kiÓu ®Çu, nghÜa lµ TYPE_1, TYPE_2 TYPE_3vµ 
TYPE_SPIRAL. 

Sau khi ®iÒn hÕt c¸c th«ng sè chän menu File, Save trªn hép tho¹i, sau ®ã chän File ⇒ 
Exit ®Ó ra ngoµi. 

5. Sufaces: Chän c¸c bÒ mÆt h×nh thµnh hèc, gåm c¸c thµnh vµ ®¸y. Xong, chän  Model ⇒ 
Done ⇒ Add, chó ý dïng Query Sel, xong chän Done Sel ⇒ Done ⇒ Done Return. 

 

§Ó kiÓm tra kÕt qu¶, chän Play 
Path ⇒ Screen Play. Sau mét l¸t chê 
tÝnh to¸n, ta sÏ nh×n thÊy dao ch¹y vµ 
®−êng quü ®¹o dao ®−îc vÏ ra d−íi 
d¹ng khung d©y. §Ó m« pháng d−íi 
d¹ng Solid, chän NC Check ⇒ Run. 
Trong h×nh 19 lµ kÕt qu¶ Play Path vµ 
NC Check b−íc gia c«ng Pocketing. 

NÕu chÊp nhËn kÕt qu¶ th× chän 
Done/Return ⇒ Done Sequ ®Ó nhËn 
NC Sequence võa t¹o vµ kÕt thóc. H×nh 19: KÕt qu¶ gia c«ng Profile 

3. Khoan c¸c lç ∅10 (Holemaking) 
B−íc nµy khoan 6 lç cïng ®−êng kÝnh ∅10. 
Trong Menu Manager chän Machining ⇒ NC Sequence ⇒ New Sequence ⇒ 

Machining ⇒ Holemaking ⇒ Done ⇒ Drill ⇒ Standard ⇒ Done. Trong menu bªn d−íi, 
®¸nh dÊu c¸c « Name, Comments, Tool, Parameters, vµ Holes, sau ®ã chän Done. 

Chó thÝch: Víi ph−¬ng ph¸p Holemaking (t¹o lç) cã nhiÒu chu tr×nh gia c«ng kh¸c nhau 
®Ó chän: 
 + Drill (Khoan) 
  - Standard (mÆc ®Þnh): Khoan th−êng. 
  - Deep: Khoan s©u. 
  - Break chip: Cã bÎ phoi. 
  - Web: t¹o r·nh. 
  - Back: V¸t phÝa sau lç 
 + Face (Kho¶ ®¸y): Cã dõng dao ®Ó kho¶ ®¸y lç. 
 + Bore (Doa): Doa tinh kÝch th−íc ®−êng kÝnh. 
 + Countersink (Doa miÖng): V¸t miÖng lç. 
 + Tap (Taro): Taro ren trong lç 
  - Fixed (Cøng): Phèi hîp chÝnh x¸c tèc ®é trôc chÝnh vµ ch¹y dao ®Ó cã b−íc ren 
chÝnh x¸c. M¸y CNC ph¶i cã kh¶ n¨ng ®Þnh h−íng trôc chÝnh. 
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  - Floating (B¬i): Cho phÐp hiÖu chØnh l−îng ch¹y dao nhê tham sè 
FLOAT_TAP_FACTOR. 
 + Ream (KhoÐt): KhoÐt tinh lç b»ng dao khoÐt. 
 + Custom: Cho phÐp t¹o chu tr×nh riªng cho m¸y cô thÓ. 

Trong bµi nµy, chän chu tr×nh khoan tiªu chuÈn Drill ⇒ Standard. 
LÇn l−ît nhËp c¸c th«ng tin sau: 
1. Name: Gâ tªn "Drill1". 
2. Comments: Gâ chó gi¶i, vÝ dô "Khoan cac lo D10" ⇒ OK. 
3. Tool: NhËp c¸c th«ng sè dao nh− trong h×nh 20. Tõ menu File cña hép tho¹i chän 

Done. 
4. Parameters: Chän Set trong Menu Manager, xuÊt hiÖn hép tho¹i Param Tree cho 

khoan (Drilling) nh− trong h×nh 21. 

  
H×nh 20: NhËp mòi khoan H×nh 21: Th«ng sè khoan 
X¸c ®Þnh c¸c th«ng sè c«ng nghÖ vµ ®iÒn vµo b¶ng cña hép tho¹i. ý nghÜa cña c¸c th«ng 

th«ng sè míi gÆp nh− sau: 
BREAKOUT_DISTANCE: Kho¶ng ch¹y qu¸ cña mòi khoan, th−êng dïng khi khoan lç 

th«ng. 
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SCAN_TYPE: Quy ®Þnh thø tù 
khoan c¸c lç. Cã mét sè lùa chän sau 

(xem h×nh 22). 
1. TYPE_1: Ch¹y theo chiÒu 

d−¬ng cña trôc Y vµ ch¹y ®i ch¹y l¹i 
theo trôc X (h×nh bªn tr¸i). 
2. TYPE_SPIRAL: Vßng theo chiÒu 
kim ®ång hå (h×nh gi÷a). H×nh 22: C¸c kiÓu khoan 

3. TYPE_ONE_DIR: Theo chiÒu t¨ng X, gi¶m Y (h×nh bªn ph¶i). 
4. SHORTEST: HÖ thèng tù x¸c ®Þnh thø tù khoan sao cho kho¶ng ch¹y kh«ng lµ ng¾n 

nhÊt (mÆc ®Þnh). 
 

 

CLEAR_DIST: §iÓm kÕt thóc ch¹y dao 
nhanh, b¾t ®Çu ch¹y dao víi tèc ®é gia c«ng. Gi¸ 
trÞ mÆc ®Þnh lµ -1. 

CLEARANE_OFFSET: §iÓm an toµn, bï 
thªm vµo CLEAR_DIST. NÕu nhËp gi¸ trÞ mÆc 
®Þnh (-), lÊy ®iÓm CLEAR_DIST. 

PULLOUT_DIST: §iÓm dõng dao sau khi 
khoan. Gi¸ trÞ mÆc ®Þnh (-), dïng chÝnh ®iÓm 
CLEAR_DIST. 

X¸c ®Þnh c¸c th«ng sè c«ng nghÖ vµ ®iÒn vµo 
b¶ng cña hép tho¹i. ý nghÜa cña c¸c th«ng th«ng 
sè míi gÆp nh− sau: 

BOTTOM_SCALLOP_HGT: ChiÒu s©u líp 
c¾t ë ®¸y khi gia c«ng khèi (Volume Milling). 

Sau khi nhËp c¸c th«ng sè c«ng nghÖ, trong 
hép tho¹i chän menu File ⇒ Exit vµ Done trong 
Menu Manager. 

5. Hole set: Chän lç ®Ó khoan. 
Pro/E cho phÐp khoan mét tËp hîp lç (Hole 

Set) trong mét b−íc theo c¸c ph−¬ng ph¸p kh¸c 
nhau nh− trong hép tho¹i HoleSet (h×nh 23). H×nh 23: Hép tho¹i chän lç 
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PhÇn trªn cña hép tho¹i (Hole Selection) cho 6 ph−¬ng ph¸p chän c¸c lç khoan: 
1. Axes: Cho phÐp chän tõng lç nhê ®−êng t©m. 
2. Group: Chän mét nhãm lç ®· ®−îc thiÕt lËp tõ tr−íc. 
3. Points: Trùc tiÕp chän vÞ trÝ khoan nhê ®iÓm chuÈn (Datum Point) trªn m« h×nh hoÆc ®äc 

to¹ ®é c¸c ®iÓm chuÈn tõ b¶ng d÷ liÖu. 
4. Diameters: Chän c¸c lç cã cïng ®−êng kÝnh. 
5. Surfaces: Chän c¸c lç cïng n»m trªn mét bÒ mÆt. 
6. Parameters: Chän mét lç theo th«ng sè nµo ®ã. 
Cã thÓ phèi hîp c¸c ph−¬ng ph¸p kÓ trªn ®Ó chän tËp hîp lç. Riªng ph−¬ng ph¸p chän theo 

®iÓm kh«ng thÓ phèi hîp víi c¸c ph−¬ng ph¸p kh¸c. 
PhÇn d−íi cña hép tho¹i (Options) ®−a ra c¸c tuú chän ®Ó x¸c ®Þnh th«ng sè tiÕp theo cña 

lç: 

 

1. Depth: X¸c ®Þnh chiÒu s©u cña 
lç. Sau khi chän Depth, hép tho¹i Hole 
Set Depth xuÊt hiÖn (h×nh 24). Cã thÓ 
lùa chän 1 trong 3 tiªu chÝ: 

- Blind: ChØ ®iÓm ®Çu vµ ®iÓm cuèi 
cña lç khoan b»ng c¸ch nhËp c¸c gi¸ trÞ 
Z hoÆc chän c¸c bÒ mÆt t−¬ng øng. 

- Auto: ChiÒu s©u lç ®−îc x¸c 
®Þnh tù ®éng theo kÝch th−íc thiÕt kÕ, 
NÕu cã c¸c lç trïng t©m nhau th× chiÒu 
s©u lín nhÊt ®−îc chän miÔn lµ ®−êng 
kÝnh dao trïng víi ®−êng kÝnh lç. 
H×nh24 cho vÝ dô vÒ tr−êng hîp võa 
nªu.  

H×nh 24: Hép tho¹i x¸c ®Þnh  
chiÒu s©u lç 

- Through All: Khoan th«ng tÊt c¶ 
c¸c ph«i hoÆc c¸c chi tiÕt ®−îc chän. Cã 
thÓ dïng Delect, Select All hoÆc Unselect 
®Ó chän, th«i chän c¸c ph«i hoÆc chi tiÕt 
cÇn ®−a vµo tÝnh chiÒu s©u lç. 

Môc Tool Depth cho phÐp  tÝnh 
chiÒu s©u lç theo Tip (®Ønh mòi khoan) 
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hoÆc Shoulder (phÇn th©n) nh− minh 
ho¹ trong h×nh 25. 

2. Use Prev: Chän tËp hîp lç cã 
trong b−íc tr−íc ®ã vµ cã thÓ thªm, bít 
theo yªu cÇu cña  b−íc míi. 

3. Auto Chamfer: NÕu ®¸nh dÊu 
tuú chän nµy th× c¸c lç ®−îc tù ®éng 
v¸t miÖng. KÝch th−íc v¸t tuú thuéc 
kÝch th−íc dao ®ang dïng. 

H×nh 25: Tuú chän chiÒu s©u 

Trong bµi nµy, chän Diameter ⇒ Chän 10 trong hép tho¹i Select Hole Diameter. Trong 
hép tho¹i Hole Set Depth, chän Auto vµ Tip ⇒ OK ⇒ OK. 

 

§Ó kiÓm tra kÕt qu¶, chän Play 
Path ⇒ Screen Play . Sau mét l¸t chê 
tÝnh to¸n, ta sÏ nh×n thÊy dao ch¹y vµ 
®−êng quü ®¹o dao ®−îc vÏ ra d−íi 
d¹ng khung d©y. §Ó m« pháng d−íi 
d¹ng Solid, chän NC Check ⇒ Run. 

Trong h×nh 26 lµ ®−êng ch¹y dao 
®−îc h×nh thµnh. 

NÕu chÊp nhËn kÕt qu¶ th× chän 
Done/Return ⇒ Done Sequ ®Ó nhËn 
NC Sequence võa t¹o vµ kÕt thóc. H×nh 26: Thø tù khoan c¸c lç ∅10 

4. Khoan lç ∅15 
Trªn chi tiÕt cã 1 lç ∅15. Thñ tôc lËp tr×nh khoan lç nµy t−¬ng tù nh− khoan c¸c lç ∅10, 

chØ kh¸c trong hép tho¹i Select Hole Diameter, chän Diameter = 10. 
§Õn ®©y, chóng ta ®· thùc hiÖn xong 4 b−íc cña nguyªn c«ng Phay1. §Ó kiÓm tra toµn bé 

nguyªn c«ng, trong Menu Manager chän CL Data ⇒ Ouput ⇒ Operation. Trong danh môc, 
chän Phay1. Chän c«ng cô xuÊt file: Play Path ⇒ Screen Play ⇒ Done sÏ nhËn ®−îc quü ®¹o 
dao gia c«ng. §Ó m« pháng, chän NC Check ⇒ Run. KÕt qu¶ gia c«ng ®−îc thÓ hiÖn nh− trong 
h×nh 27. 
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H×nh 27: M« pháng gia c«ng nguyªn c«ng Phay1 

 
2.4. Ghi vµ sö dông CL Data file 

Cho ®Õn ®©y, c¸c d÷ liÖu míi chØ ®−îc l−u tr÷ trong file m« h×nh gia c«ng. CÇn ph¶i xuÊt d÷ liÖu 
nµy ra CL Data file ®éc lËp, ®Ó tõ ®ã cã thÓ t¹o ra file d÷ liÖu ®iÒu khiÓn m¸y CNC (ch−¬ng tr×nh 
NC). Muèn t¹o ra ch−¬ng tr×nh NC, ph¶i cã Post-Processor. PhÇn mÒm Pro/E tiªu chuÈn chØ cã 
thÓ t¹o ra CL Data File d−íi d¹ng ng«n ng÷ APT. 

1. XuÊt CL Data ra file 
Trong Menu Manager, chän Manufacture ⇒ Machine ⇒ CL Data ⇒ Output   ⇒ 

Select set => Creat ⇒ tªn Operation hoÆc tªn NC Sequence. Më menu CREAT SET chän toµn 
bé c¸c nguyªn c«ng, råi chän Done Sel. 
⇒ File. Trong menu Output Type, ®¸nh dÊu CL File vµ Interactive  ⇒ Done. Trong hép tho¹i 
Save As, chän New File ⇒ (gâ tªn file, vÝ dô Bai1) ⇒ OK. KÕt qu¶, nhËn ®−îc file Bai1.NCL. 

2. §äc d÷ liÖu tõ file 
Sau khi khëi ®éng Pro/E, tõ menu File ⇒ Open ⇒ Chän tªn file (Bai1.mfg) ⇒ Open. 

M« h×nh gia c«ng xuÊt hiÖn trªn mµn h×nh ®å ho¹. 
Tõ Menu Manager, chän CL data ⇒ Operaton ⇒ tªn nguyªn c«ng (Phay1) ⇒ Display ⇒ 
Done. Sau mét thêi gian tÝnh to¸n, quü ®¹o dao sÏ ®−îc vÏ trªn m« h×nh gia c«ng. 

Muèn ch¹y m« pháng, chän NC Check ⇒ Run. 
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